Recent Posts

Pages: [1] 2 3 ... 10
1
General Public Discussion / Re: Or Operator
« Last post by Nymphis on May 22, 2018, 04:50:53 AM »
Cheers Jack :)
2
General Public Discussion / Re: Or Operator
« Last post by Jack on May 21, 2018, 03:03:30 PM »
You can string together as many as you want. Check out the order of operations in most computer languages to see how a long expression will compute or just use brackets to organize it how you want it to be computed.
3
General Public Discussion / Re: Or Operator
« Last post by Nymphis on May 20, 2018, 04:39:32 PM »
Ah!  yes I see the Logic now :)
For the Loop while to stop i need it to see a false and the & Operator does this if either XX or AA is True.

one last question Jack, I assume I can only have 2 x expressions? one to the left and one to the right of &?
Or can I string 4 or 5 together?
4
General Public Discussion / Re: Or Operator
« Last post by Jack on May 20, 2018, 04:00:55 PM »
If you want the loop to stop when either XX or AA is true then you set up the statement wrong.
Since you only want the loop to continue when they are both false you probably want to use an And operator instead.
It would prob be something like this:
Loop While (XX = False & AA = False)
if that doesnt work try this:
Loop While ((XX = False) & (AA = False))
5
General Public Discussion / Or Operator
« Last post by Nymphis on May 20, 2018, 06:05:23 AM »
Hi Jack

I have a Question regarding the "Or Operator"
In the instructions the Symbol used is |  but I can not seem to get this to work.

I have a simple "Loop While" command that looks like this.

Loop while (XX = False | AA = False)

Within this Loop While I am checking for the condition of XX and AA.
Theory is that the Loop with stop if either XX or AA = True.
I have checked the Global Variable XX and AA and the are changing correctly, but the loop keeps running even when if one of them is true.


I look forward to your feed back.
6
General Public Discussion / Re: ESO bot coming?
« Last post by dwill on May 11, 2018, 05:59:42 AM »
Rather than making a new thread I'll borrow this one.  I'd pay good money for an ESO setup.  The expansion releases at the end of this month and the N/A Megaserver is packed.  The topic of macro use in ESO is widely discussed as well so I'd imagine there's a market for it.  As I mentioned already; I'd be one of them!

Thanks
7
General Public Discussion / Re: FindBitmap Functions
« Last post by Jack on April 21, 2018, 12:25:24 PM »
That's interesting. glad you got it figured out
8
General Public Discussion / Re: FindBitmap Functions
« Last post by Nymphis on April 21, 2018, 05:49:32 AM »
Hi Jack
So after some testing today I worked it out.

It seems the quality of Image in BDO with the new 1080GTX card is so good that the standard Windows Paint can not be used to crop and save the BMP images.
I tried it with GIMP and the FindBitMap Function is working as intended.

Its weird, but you can definitely see the difference between Cropping with Paint and GIMP.
I assume it worked before the graphic card upgrade because I was running the game at low settings, But with cropping the Icons/Images I need in Gimp I can now use very low settings on the ColorVariance...where before I would always have to be around 90 (which made the Function jump to incorrect icons at times)

So it seems like a good time to re-write a lot of the old code and freshen it up....Lucky for me I love the logic challenges :D

Keep up the great work Jack...MacroGoblin is Awesome :D


9
General Public Discussion / Re: FindBitmap Functions
« Last post by Nymphis on April 11, 2018, 07:44:27 AM »
Hi Jack
Thank you for your reply.
I normally play game in full screen windows, but I'll check out the Aero setting.

I was planning do test some more ideas this weekend. I'll keep up posted if I find anything :)
10
General Public Discussion / Re: FindBitmap Functions
« Last post by Jack on April 09, 2018, 11:41:23 AM »
It might be possible for BDO to do that, but if ReadPixel works fine they probably didn't. The graphic quality shouldnt be too good for the function, unless it uses some non-standard display method in windows.

The only ohter thing i can think of, which you've probably already done, is to make sure you're running windows in a non-aero them. Aero is the them where the window borders can be semi-transparent but it also messes with pixel reading functions. Go to some simple solid window border theme if possible.
Pages: [1] 2 3 ... 10